Buenos dias, de antemano gracias a todos por sus aportes.

Mi consulta va dirigida a unas fallas que me encuentro presentando con unas lámparas leds submarinas.

Estas lamparas estan compuestas por una parte que se alimenta de 230 volts AC y una parte de control de 0-10volts DC para controlar el encendido y apagado de la misma, asi como la intensidad de la luz. Por ejemplo, 0 es apagada, 5 es a la mitad de la potencia y 10 es completamente encendida.

El inconveniente que estoy presentando es que, al filtrarse las lámparas con agua (estan sumergidas en el mar) ocurre en ellas algo que me quema la fuente de poder de 0-10volts que les conecto para controlarlas. Inicialmente lo que se me viene a la mente es un corto circuito en la parte de control que finalmente acaba por quemar mi fuente de poder.

He colocado un circuito electronico que he pillado en internet https://www.youtube.com/watch?v=yFO1TXiYvP0&t=260s el cual se activa al haber un corto. Lo he probado haciendo un corto circuito manualmente con la lámpara fuera del agua y me funciona a la perfección. Efectivamente se activa y me corta el flujo de corriente hacia la lámpara en corto.

El problema es que al probar la lámpara en el agua de mar (provocando una filtración) no obtengo el mismo efecto. La lámpara comienza a cortocircuitarse pero se mantiene parpadeando todo el rato. El circuito anteriormente comentado no se me activa por lo que la fuente de control sigue alimentando la lámpara por lo que no me queda claro realmente que pasa. Si realmente se me cortocircuita la fuente o no porque fuera del agua haciendo el cortocircuito manual funciona pero al hacerlo con el agua no pasa.

Por otro lado, aun con la lampara dentro del agua hago un cortocircuito manual y se me activa el circuito que les comente anteriormente pero ahora en las punta de 0-10 de la lampara obtengo 5-6volts apróx.

Que podria pasar?? me siento confundido. Que podría probar para detectar la falla?